Björn Johnsson

Dr. Björn Johnsson

Lund University, Department of Computer Science
orcid

Research Focus & Metrics

Academic Career Length

14Years (2013-Present)

(Calculated once Scilit publication data is synced: current year − year of first publication + 1)

Representative Publications

View All Publications
RLRose-Marie Lindkvist
Rose-Marie Lindkvist
ASAnnics Sjöström Strand
Annics Sjöström Strand
KLKajsa Landgren
Kajsa Landgren
BJBjörn Johnsson
Björn Johnsson
PSPernilla Stenström
Pernilla Stenström
Inger Kristensson HallströmInger Kristensson Hallström
Inger Kristensson Hallström
The costly and complex needs for children with long-term illness are challenging. Safe eHealth communication is warranted to facilitate health improvement and care services. This mixed-methods study aimed to describe parents’ usage and experiences of communicating with professionals during hospital-to-home-transition after their child’s preterm birth or surgery for colorectal malformations, using an eHealth device, specifically designed for communication and support via nurses at the hospital. The eHealth devices included the possibility for daily reports, video calls, text messaging, and sending images. Interviews with 25 parents were analyzed with qualitative content analysis. Usage data from eHealth devices were compiled from database entries and analyzed statistically. Parents using the eHealth device expressed reduced worry and stress during the initial period at home through effective and safe communication. Benefits described included keeping track of their child’s progress and having easy access to support whenever needed. This was corroborated by usage data indicating that contact was made throughout the day, and more among families living far away from hospital. The eHealth device potentially replaced phone calls and prevented unnecessary visits. The eHealth technique can aid safe self-treatment within child- and family-centered care in neonatal and pediatric surgery treatment. Future research may consider organization perspectives and health economics.

6 November 2016
Verified
Book Chapter
Closed access
PDF file
BJBjörn Johnsson
Björn Johnsson
MHMartin Höst
Martin Höst
BMBoris Magnusson
Boris Magnusson

23 December 2013 in arXiv
Verified
Preprint
Open access
PDF file
TSThomas Sandholm
Thomas Sandholm
BMBoris Magnusson
Boris Magnusson
BJBjörn Johnsson
Björn Johnsson
In this paper we present the implementation of a WebRTC gateway service that can forward ad-hoc RTP data plane traffic from a browser on one local network to a browser on another local network. The advantage compared to the existing IETF STUN (RFC 5389), TURN (RFC 5766) and ICE (RFC 5245) protocols is that it does not require a public host and port mapping for each participating local host, and it works with more restrictive firewall policies. WebRTC implements ICE which combines STUN and TURN probes to automatically find the best connection between two peers who want to communicate. In corporate networks, simple hole punching and NAT traversal techniques typically do not work, e.g. because of symmetric NATs. Dynamic allocation of ports on an external 3rd party relay service is also typically blocked on restricted hosts. In our use case, doctors at hospitals can only access port 80 through the hospital firewall on external machines, and they need to communicate with patients who are typically behind a NAT in a local WiFi network. VPN solutions only work for staff but not between patients and staff. Our solution solves this problem by redirecting all WebRTC traffic through a gateway service on the local network that has a secure tunnel established with a public gateway. The public gateway redirects traffic from multiple concurrent streams securely between local gateway services that connect to it. The local gateways also communicate with browsers on their local network to mimic a direct browser-to-browser connection without having to change the browser runtime. We have demonstrated that this technique works well within the hospital network and arbitrary patient networks, without the need for any individual host configuration. In our evaluation we show that the latency overhead is 18-20 ms for each concurrent stream added to the same gateway service.